✓ Beim schließen Fehlermeldungen

Home Foren Patchwork 1 & 2 Arbeiten mit Patchwork Unerklärliches ✓ Beim schließen Fehlermeldungen

Dieses Thema enthält 7 Antworten und 3 Teilnehmer. Es wurde zuletzt aktualisiert von pondo pondo vor 7 Monate, 1 Woche.

Ansicht von 8 Beiträgen - 1 bis 8 (von insgesamt 8)
  • Autor
    Beiträge
  • #33822
    dito
    dito
    Teilnehmer
    • Beiträge: 5
    • schaut mal rein

    Hallo zusammen. Teste grade Patchwork aus und beim schließen des Programms hagelt es acht Fehlermeldungen. Allerdings nicht immer. So alle drei bis vier Mal.

    Da steht dann immer was von:

    Zugriffsverletzung bei Adresse XY…

    Ich hänge mal eins von den acht Meldungen als Bild mit dran.

     

    Lieben Gruß

    Tom

    fehler 3

    Dateianhänge:
    You must be logged in to view attached files.
    #33824
    martin
    martin
    Keymaster
    • Beiträge: 3987
    • Käpt'n

    Hallo dito,

    dazu fallen mir adhoc nur drei mögliche Gegebenheiten ein:

    1. Ist die Installation fehlerfrei durchgelaufen ohne ein einziges Mal ›überspringen‹?
    2. Ist der Projektordner in einem von einer Cloud gesicherten Bereich? Auch OneDrive ist eine Cloud. Wenn ja: Das darf deshalb nicht sein, weil Patchwork z.B. beim Beenden viele Daten zurückschreibt und Clouds dafür zu langsam sind. Daten sind gesperrt und es kommt zu Fehlermeldungen.
    3. Kommt keine Frage, ein Protokoll an uns zu schicken? Wenn das nicht der Fall ist, liegt die Wahrscheinlichkeit hoch, dass etwas von außen stört. Was allerdings, damit kann ich leider nicht helfen. Das kann von einem Virenprogramm bis zu einem defekten Maustreiber alles Mögliche sein.

    Übrigens helfen diese Meldungen ohne Report leider nicht bei einer Fehlerlokalisierung. Und wenn es einen Report gibt, dann bitte nicht hier posten, sondern mailen.

    Viele Grüße
    Martin

     

    #33825
    dito
    dito
    Teilnehmer
    • Beiträge: 5
    • schaut mal rein

    Vielen Dank für die schnelle Antwort.

    Nein, keine Cloud Installation und das Testprojekt liegt auf dem Desktop. Die Installation lief sauber durch. Allerdings gab es eine Warnung von Windows 10, dass das Programm nicht sicher sei. (Das passierte auch schon beim Download der patchwork exe im Browser.)

    Eine Frage bezüglich des versenden eines Protokolls gab es leider nicht.

    Ich schaue mir das noch mal in Ruhe an und wenn ich nicht weiter komme, melde ich mich kommende Woche per Mail.

    Nochmal vielen Dank und ein entspanntes Wochenende.

    #33826
    martin
    martin
    Keymaster
    • Beiträge: 3987
    • Käpt'n

    Hallo dito,

    Warnungen von Windows können dann kommen, wenn man nicht eines der sündteuren Zertifikate hat, die ansonsten für nichts sind. Vermutlich wird die eine oder andere Zertizierungsstelle zur Bill-and-Melinda-Gates-Stiftung gehören :-)

    Übrigens kommt die Tage Patchwork3 heraus, vielleicht magst du es dann damit mal probieren. Näheres findest du hier im Forum unter den Ankündigungen.

    Dann frohe Ostern derweil!

    Viele Grüße
    Martin

    #33836
    pondo
    pondo
    Teilnehmer
    • Beiträge: 98
    • übernachtet manchmal

    Hi allerseits,

    ich glaube, ich kann helfen. Ich hatte den Fehler auch schon und hab ihn eingrenzen und reproduzieren können. Vielleicht liegt es bei dir natürlich auch an etwas anderem, aber ich habe wie du auch beim Schließen teils sieben, acht oder noch mehr Fehlermeldungen genau dieser Art erhalten. Gut möglich also, dass wir dasselbe (simple) Problem hatten, das wie folgt aussieht:

    dito, schau mal, ob du unter Einstellungen-Allgemein-“Elemente sanft auf-/zurollen (anstatt auf-/zuklappen)” das standardmäßig gesetzte Häkchen entfernt hast und ggf. in deiner Session die Werkzeugleiste mit den Stil-Anregungen auf- und zugeklappt hast. Falls ja, dann kann Folgendes helfen, denn das Entfernen des Häkchens in den Einstellungen produziert – bei mir zumindest – Fehler, die sich als Folge ergeben haben, aber eben auch verhindern lassen. Im Grunde ist es ganz simpel (indem man das Häkchen in den Einstellungen gesetzt lässt), aber für Martin schreibe ich hier auch nochmal ausführlich hin:

    (1) Zur Reproduzierbarkeit des Fehlers
    (2) Lösung

    ——-
    (1) Zur Reproduzierbarkeit des Fehlers

    Der Fehler muss einerseits mit folgender Einstellung zusammenhängen – unter: Einstellungen -> Allgemein -> “Elemente sanft auf-/zurollen (anstatt auf-/zuklappen)” -> Häkchen entfernen
    und andererseits mit den Stil-Anregungen, im Speziellen mit dem Auf- und Zuklappen von deren Werkzeugleiste.

    Standardmäßig ist das Häkchen unter [Einstellungen-> Allgemein-> “Elemente sanft auf-/zurollen (anstatt auf-/zuklappen)”] ja gesetzt. Wenn man es aber entfernt (um das auf-/zuklappen zu aktivieren) und die Einstellungen schließt und damit speichert, dann reicht es schon, im Editor die Werkzeugleiste mit den Stil-Anregungen danach einmal aufzuklappen und wieder zuzuklappen (oder, sollte sie vorher ausgeklappt gewesen sein, sie zuzuklappen, aufzuklappen und wieder zuzuklappen) und dann Patchwork zu schließen. Dann kommt beim Beenden von Patchwork die Fehlermeldung “Zugriffsverletzung bei Adresse 00CBA524 in Modul ‘Patchwork.exe’. Lesen von Adresse 000007A8.”

    Startet man nun Patchwork neu, tritt nun (wenn man als letztes die Werkzeugleiste der Stil-Anregungen zugeklappt hat) das Phänomen auf, dass die Werkzeugleiste nach dem Start dennoch aufgeklappt ist, jedoch der Button, mittels dessen man die Leiste auf-/zuklappt, das nicht wie sonst anzeigt (sozusagen “eingedrückt” ist). Vor allem lassen sich dann auch die Stil-Anregungen selbst nicht benutzen. Erst wenn man die Leiste nochmal zuklappt und wieder aufklappt und DANN Patchwork beendet, kommt zwar beim Beenden nochmal der Fehler, aber dann lassen sich die Stil-Anregungen beim nächsten Start von Patchwork wieder nutzen. Hatte man wiederum beim Beenden die Werkzeugleiste zugeklappt und, vorm Zuklappen dieser, dazu noch ein bisschen auf verschiedenen Stil-Anregungen-Knöpfen herumgedrückt, so erscheinen dann zahlreiche weitere Fehlermeldungen beim Beenden. Soll heißen, es erscheinen nicht nur ein oder zwei Fehlermeldungen, sondern ggf sechs oder sieben oder so.
    Wohlgemerkt: Wenn man die Werkzeugleiste einfach von Start an aufgeklappt lässt, lässt sich weitgehend ohne Fehlermeldung zum Schluss arbeiten. Wenn man sie wiederum innerhalb einer Sitzung auf-/zuklappt, kommt (zumindest bei mir) sicher eine Fehlermeldung wie oben geschrieben (mit verschiedenen genannten Adressen, meist entweder Adresse 00CBA524, Adresse 00CB9D24 oder Adresse 00CDC33C).
    ——

    ——
    (2) Zur Lösung

    Das Ganze lässt sich dann aber auch wieder abstellen, indem man in den Einstellungen unter Allgemein den Haken bei “Elemente sanft auf-/zurollen (anstatt auf-/zuklappen)” wieder setzt. Beendet man die Einstellungen und speichert diese und beendet Patchwork, kommt zwar noch einmal eine Fehlermeldung, aber ab dem nächsten Start dann ist alles wie gehabt – oder beim übernächsten, sollte man evtl nochmal die Werkzeugleiste Stil-Anregungen richtig ein- und wieder ausklappen müssen. Spätestens beim Start drauf ist dann wieder alles ok und man in der Werkzeugleiste der Stil-Anregungen herumfuhrwerken und sie auf- und zuklappen, wie man lustig ist, dann kommt beim Beenden kein Fehler mehr.
    ——-

    Ich hoffe, ich konnte damit helfen. :)

    Viele Grüße
    p.

    #33837
    dito
    dito
    Teilnehmer
    • Beiträge: 5
    • schaut mal rein

    Vielen lieben Dank Pondo für die Hilfe.

    Genau das ist es!

    Mich hatte schon gewundert, warum die Stilanregungen bei jedem Programmstart immer ausgeklappt waren und auch der Lesbarkeitsindex nicht mehr funktionierte. Ich habe deine ausgeführten Schritte befolgt und die Fehlermeldungen sind verschwunden.

    Lieben Gruß

    Tom

    #33843
    martin
    martin
    Keymaster
    • Beiträge: 3987
    • Käpt'n

    Hallo pondo,

    super, deine kriminalistische, ausführliche Arbeit und Dokumentation, vielen Dank! Wäre ich Police-Officer, würde ich anerkennend nicken und sagen: »Gute Arbeit!«

    Nun bin ich beinahe geneigt, das Adverb ›leider‹ vor den Starttermin übermorgen von Patchwork3 zu setzen, weil wir so deine Erkenntnis nicht mehr umsetzen können. Da Patchwork großteils neu geschrieben (also nicht erweitert wie bisher) worden ist, gibt es diese Situation nicht mehr und auch die Umsetzungen sind anders.

    Ich finde aber dein Engagement und deine Findigkeit großartig!

    Viele Grüße
    Martin

    #33862
    pondo
    pondo
    Teilnehmer
    • Beiträge: 98
    • übernachtet manchmal

    Hi Martin,

    ah, zu viel der Ehre, aber wenn Tom so zumindest kurzfristig geholfen ist, die Freude an Patchwork zu entdecken, freut mich das. Und auf Patchwork 3 freuen wir uns schließlich alle! :)

    In diesem Sinne: Bis morgen!
    Viele Grüße
    pondo

Ansicht von 8 Beiträgen - 1 bis 8 (von insgesamt 8)

Du musst angemeldet sein, um auf dieses Thema antworten zu können.